Anzeige - [Hier werben]
(?) Tags raten (?) argosoft, mailserver (edit)
Seiten: (2) [1] 2  ( Neuster Beitrag anzeigen )
Reply to this topicStart new topicStart Poll
Diskussion

[ArGoSoft Mailserver]Versendet keine Mail...

Gast
Geschrieben am: Do 15.07.2004, 19:16
Report PostQuote Post

Unregistered







Hallo Leute, ich hab ein Problem mit meinem Mailserver...
ich habe ihn gerade nach der Anleitung von
hier
konfiguriert, allerdings bekomm ich keine Mails auf den Weg.

So sieht die Logfile aus:

CODE
15.07.2004 20:08:56 - SMTP Server started. Listening on port 25
15.07.2004 20:08:56 - POP3 Server started. Listening on port 110
15.07.2004 20:08:56 - Finger Server started. Listening on port 79
Message size limit 5 MB
Winsock version: $0101
High version: $0202
Description: WinSock 2.0
System status: Running
Maximum sockets: 32767
Local host: webserver-main
Local addresses: 192.168.0.100
Local host after reverse lookup: webserver-main
15.07.2004 20:09:01 - [    31] Winsock error when communicating with exchanger mailin03.sul.t-online.de.: [10060] Connection timed out
15.07.2004 20:09:01 - [    31] Trying the server mailin04.sul.t-online.de.: 194.25.134.10
15.07.2004 20:09:22 - [    31] Winsock error when communicating with exchanger mailin04.sul.t-online.de.: [10060] Connection timed out
15.07.2004 20:09:22 - [    31] Trying the server mailin05.sul.t-online.de.: 194.25.134.74


Den Winsock Error bringt er dann immer und immer wieder.
Hab mal testweise Zonealarm ausgeschaltet, bringt aber nix. Der Router forwarded die Ports 25/110 auf den Webserver.
Kann mir einer sagen, woran es liegt?

Vielen Dank,
Stefan

Top
Top
 
 
Irene
irene.ch
#2 Geschrieben am: Do 15.07.2004, 21:22 (+02:06)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Ist noch schwierig hier den Fehler zu sehen; das Log sieht nicht ganz komplett aus.

Nachdem die lokale IP-Adresse (Local addresses: 192.168.0.100) eine private Adresse ist, müsste der Router für ausgehende Verbindungen von dieser IP NAT machen, sprich die private auf eine öffentliche Adresse ummünzen. Tut er das?

Die Zeilen
15.07.2004 20:09:01 - [ 31] Trying the server mailin04.sul.t-online.de.: 194.25.134.10
15.07.2004 20:09:22 - [ 31] Winsock error when communicating with exchanger mailin04.sul.t-online.de.: [10060] Connection timed out

bedeuten, der Argo versucht mit einem T-Online-Server Mail auszutauschen, hat aber ein Verbindungsproblem. Das kann entweder eine ISDN-Verbindung sein, die beendet wurde, oder ein ADSL-/Kabelrouter - oder Zonealarm o.ä. - der diese Verbindung nicht erlaubt. Müsste man in der Konfiguration des Routers nachschauen.

Was sicher erstmal nützlich wäre: zwei lokale Domains mit je einem Account auf dem Argo einrichten und versuchen, zwischen diesen zwei Adressen mittels Outlook Express o.ä. Mails hin und her zu schicken. Wenn das dann geht, von diesem Server aus per Telnet auf einen öffentlichen Mailserver (z.B. den von T-Online), Port 25, zu verbinden. Kommt dann vom öffentlichen Mailserver eine Antwort wie 220 mailin04.sul.t-online.de T-Online ESMTP receiver fssmtpd ready., ist die netzwerkmässige Verbindung in Ordnung und der Argosoft sollte Mails verschicken können. Wenn er dann immer noch nicht kann, liegt das Problem an der Konfiguration vom Argo.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Gast
#3 Geschrieben am: Do 15.07.2004, 23:02 (+01:39)
Report PostQuote Post

Unregistered







Danke erstmal für die Antwort,

ja, der Router macht NAT. Auf dem PC (192.168.0.100) laufen auch noch ein FTP, ein MySQL und ein Webserver. Die sind alle von außen erreichbar.

Was den ADSL-Router angeht..... Wie schon erwähnt werden die Ports 25 und 110 zum Server durchgereicht. Ich denke mal mehr Ports brauch ich ja nicht für den Mailverkehr. Zonealarm ist derzeit ausgeschalten, daran kanns wohl auch nicht liegen.

Das mit den 2 Accounts und dem Outlook Express versteh ich grad nicht...
Der Webserver wird nur vom Webserver auf der selben Maschine angesprochen.
E-Mails vom Intranet werden sonst nicht gesendet.
Das mit dem Telnet geht irgendwie nicht.. weder Port 23 noch 25 noch 80...

Hier mal ein paar Auszüge noch:
1. hier nochmal ein kompletter Logauszug aus Argo:


15.07.2004 23:30:08 - SMTP Server started. Listening on port 25
15.07.2004 23:30:08 - POP3 Server started. Listening on port 110
15.07.2004 23:30:08 - Finger Server started. Listening on port 79
Message size limit 5 MB
Winsock version: $0101
High version: $0202
Description: WinSock 2.0
System status: Running
Maximum sockets: 32767
Local host: webserver-main
Local addresses: 192.168.0.100
Local host after reverse lookup: webserver-main
15.07.2004 23:30:13 - Requested SMTP connection from 127.0.0.1
15.07.2004 23:30:13 - ( 108) 220 ArGoSoft Mail Server Freeware, Version 1.8 (1.8.3.2)
15.07.2004 23:30:13 - ( 108) HELO webserver-main
15.07.2004 23:30:13 - ( 108) 250 Welcome [127.0.0.1], pleased to meet you
15.07.2004 23:30:13 - ( 108) MAIL FROM:<Service@Schnorxelkuh.de>
15.07.2004 23:30:13 - ( 108) 250 Sender "Service@Schnorxelkuh.de" OK...
15.07.2004 23:30:13 - ( 108) RCPT TO:<Schnorxelkuh@T-Online.de>
15.07.2004 23:30:13 - ( 108) 250 Connection from trusted IP address. Recipient OK
15.07.2004 23:30:13 - ( 108) DATA
15.07.2004 23:30:13 - ( 108) 354 Enter mail, end with "." on a line by itself
15.07.2004 23:30:13 - [ 109] Delivering to Schnorxelkuh@T-Online.de
15.07.2004 23:30:13 - [ 109] Attempting to deliver to the domain t-online.de
15.07.2004 23:30:13 - ( 108) 250 Message accepted for delivery. <wb1l24tjswe40hg.150720042330@webserver-main>
15.07.2004 23:30:13 - [ 109] Retrieved 8 MX records for domain t-online.de
15.07.2004 23:30:13 - [ 109] Trying the server mailin01.sul.t-online.de.: 194.25.134.72
15.07.2004 23:30:13 - ( 108) QUIT
15.07.2004 23:30:13 - ( 108) 221 Aba he
15.07.2004 23:30:13 - SMTP connection with 127.0.0.1 ended. ID=108
15.07.2004 23:30:35 - [ 109] Winsock error when communicating with exchanger mailin01.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:30:35 - [ 109] Trying the server mailin02.sul.t-online.de.: 194.25.134.9
15.07.2004 23:30:56 - [ 109] Winsock error when communicating with exchanger mailin02.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:30:56 - [ 109] Trying the server mailin03.sul.t-online.de.: 194.25.134.73
15.07.2004 23:31:17 - [ 109] Winsock error when communicating with exchanger mailin03.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:31:17 - [ 109] Trying the server mailin04.sul.t-online.de.: 194.25.134.10
15.07.2004 23:31:38 - [ 109] Winsock error when communicating with exchanger mailin04.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:31:38 - [ 109] Trying the server mailin05.sul.t-online.de.: 194.25.134.74
15.07.2004 23:31:59 - [ 109] Winsock error when communicating with exchanger mailin05.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:31:59 - [ 109] Trying the server mailin06.sul.t-online.de.: 194.25.134.11
15.07.2004 23:32:20 - [ 109] Winsock error when communicating with exchanger mailin06.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:32:20 - [ 109] Trying the server mailin07.sul.t-online.de.: 194.25.134.75
15.07.2004 23:32:41 - [ 109] Winsock error when communicating with exchanger mailin07.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:32:41 - [ 109] Trying the server mailin00.sul.t-online.de.: 194.25.134.8
15.07.2004 23:33:02 - [ 109] Winsock error when communicating with exchanger mailin00.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:33:02 - [ 109] Server error: [10060] Connection timed out. Will retry in 0 hr 10 min
15.07.2004 23:43:02 - [ 110] Delivering to schnorxelkuh@t-online.de
15.07.2004 23:43:02 - [ 110] Attempting to deliver to the domain t-online.de
15.07.2004 23:43:02 - [ 110] Retrieved 8 MX records for domain t-online.de
15.07.2004 23:43:02 - [ 110] Trying the server mailin07.sul.t-online.de.: 194.25.134.75
15.07.2004 23:43:23 - [ 110] Winsock error when communicating with exchanger mailin07.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:43:24 - [ 110] Trying the server mailin00.sul.t-online.de.: 194.25.134.8
15.07.2004 23:43:45 - [ 110] Winsock error when communicating with exchanger mailin00.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:43:45 - [ 110] Trying the server mailin01.sul.t-online.de.: 194.25.134.72
15.07.2004 23:44:06 - [ 110] Winsock error when communicating with exchanger mailin01.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:44:06 - [ 110] Trying the server mailin02.sul.t-online.de.: 194.25.134.9
15.07.2004 23:44:27 - [ 110] Winsock error when communicating with exchanger mailin02.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:44:27 - [ 110] Trying the server mailin03.sul.t-online.de.: 194.25.134.73
15.07.2004 23:44:49 - [ 110] Winsock error when communicating with exchanger mailin03.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:44:49 - [ 110] Trying the server mailin04.sul.t-online.de.: 194.25.134.10
15.07.2004 23:45:10 - [ 110] Winsock error when communicating with exchanger mailin04.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:45:10 - [ 110] Trying the server mailin05.sul.t-online.de.: 194.25.134.74
15.07.2004 23:45:31 - [ 110] Winsock error when communicating with exchanger mailin05.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:45:31 - [ 110] Trying the server mailin06.sul.t-online.de.: 194.25.134.11
15.07.2004 23:45:52 - [ 110] Winsock error when communicating with exchanger mailin06.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:45:52 - [ 110] Server error: [10060] Connection timed out. Will retry in 0 hr 10 min
15.07.2004 23:55:52 - [ 111] Delivering to schnorxelkuh@t-online.de
15.07.2004 23:55:52 - [ 111] Attempting to deliver to the domain t-online.de
15.07.2004 23:55:53 - [ 111] Retrieved 8 MX records for domain t-online.de
15.07.2004 23:55:53 - [ 111] Trying the server mailin02.sul.t-online.de.: 194.25.134.9
15.07.2004 23:56:14 - [ 111] Winsock error when communicating with exchanger mailin02.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:56:14 - [ 111] Trying the server mailin03.sul.t-online.de.: 194.25.134.73
15.07.2004 23:56:35 - [ 111] Winsock error when communicating with exchanger mailin03.sul.t-online.de.: [10060] Connection timed out
15.07.2004 23:56:35 - [ 111] Trying the server mailin04.sul.t-online.de.: 194.25.134.10



2. Telnet-Versuche:

C:\>telnet 194.25.134.9
Verbindungsaufbau zu 194.25.134.9...Es konnte keine Verbindung hergestellt werde
n mit Host auf Port 23 : Verbinden fehlgeschlagen

C:\>telnet 194.25.134.9 25
Verbindungsaufbau zu 194.25.134.9...Es konnte keine Verbindung hergestellt werde
n mit Host auf Port 25 : Verbinden fehlgeschlagen

C:\>
C:\>telnet route-server.ip.att.net
CCC
############## route-server.ip.att.net ###############
######### AT&T IP Services Route Monitor ###########

This router maintains peerings with customer-facing routers
throughout the AT&T IP Services Backbone:

12.123.21.243 Atlanta, GA 12.123.133.124 Austin, TX
12.123.41.250 Cambridge, MA 12.123.5.240 Chicago,IL
12.123.17.244 Dallas, TX 12.123.139.124 Detroit, MI
12.123.37.250 Denver, CO 12.123.134.124 Houston, TX
12.123.29.249 Los Angeles, CA 12.123.1.236 New York, NY
12.123.33.249 Orlando,FL 12.123.137.124 Philadelphia, PA
12.123.142.124 Phoenix, AZ 12.123.145.124 San Diego, CA
12.123.13.241 San Francisco, CA 12.123.25.245 St. Louis, MO
12.123.45.252 Seattle, WA 12.123.9.241 Washington, DC

This router has the global routing table view from each of the above
routers, providing a glimpse to the Internet routing table from the
AT&T network's perspective.

*** Please Note:

Ping and traceroute delay figures measured with this box are unreliable,
due to the high CPU load this box experiences when complicated "show" commands
are being executed.

For questions about this route-server, send email to: jayb@att.com

#################### route-server.ip.att.net ####################

route-server>q


Verbindung zu Host verloren.




3. Pings





C:\>ping 194.25.134.9

Ping wird ausgeführt für 194.25.134.9 mit 32 Bytes Daten:

Antwort von 194.25.134.9: Bytes=32 Zeit=10ms TTL=61
Antwort von 194.25.134.9: Bytes=32 Zeit=10ms TTL=61
Antwort von 194.25.134.9: Bytes=32 Zeit=10ms TTL=61
Antwort von 194.25.134.9: Bytes=32 Zeit=10ms TTL=61

Ping-Statistik für 194.25.134.9:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 10ms, Maximum = 10ms, Mittelwert = 10ms

C:\>
C:\>ping 194.25.2.129

Ping wird ausgeführt für 194.25.2.129 mit 32 Bytes Daten:

Antwort von 194.25.2.129: Bytes=32 Zeit=10ms TTL=59
Antwort von 194.25.2.129: Bytes=32 Zeit=10ms TTL=59
Antwort von 194.25.2.129: Bytes=32 Zeit=10ms TTL=59
Antwort von 194.25.2.129: Bytes=32 Zeit=60ms TTL=59

Ping-Statistik für 194.25.2.129:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 10ms, Maximum = 60ms, Mittelwert = 22ms

C:\>ping mailin04.sul.t-online.de

Ping mailin04.sul.t-online.de [194.25.134.10] mit 32 Bytes Daten:

Antwort von 194.25.134.10: Bytes=32 Zeit=10ms TTL=61
Antwort von 194.25.134.10: Bytes=32 Zeit=10ms TTL=61
Antwort von 194.25.134.10: Bytes=32 Zeit=20ms TTL=61
Antwort von 194.25.134.10: Bytes=32 Zeit=20ms TTL=61

Ping-Statistik für 194.25.134.10:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
Minimum = 10ms, Maximum = 20ms, Mittelwert = 15ms

C:\>



4. IP-Konfiguration:


C:\>ipconfig /all

Windows 2000-IP-Konfiguration

Hostname. . . . . . . . . . . . . : webserver-main
Primäres DNS-Suffix . . . . . . . :
Knotentyp . . . . . . . . . . . . : Broadcastadapter
IP-Routing aktiviert. . . . . . . : Nein
WINS-Proxy aktiviert. . . . . . . : Nein

Ethernetadapter "LAN-Verbindung 3":

Medienstatus. . . . . . . . . . . : Kabel nicht angeschlossen
Beschreibung. . . . . . . . . . . : VIA VT6105 Rhine III Fast Ethernet A
dapter
Physikalische Adresse . . . . . . : 00-40-63-C9-F2-80

Ethernetadapter "LAN-Verbindung 2":

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : VIA Rhine II Fast Ethernet Adapter
Physikalische Adresse . . . . . . : 00-40-63-C9-F2-7F
DHCP-aktiviert. . . . . . . . . . : Nein
IP-Adresse. . . . . . . . . . . . : 192.168.0.100
Subnetzmaske. . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . : 192.168.0.1
DNS-Server. . . . . . . . . . . . : 217.5.100.129
194.25.2.129

C:\>





Ich würd ja auch tippen, dass es an Argo liegt, nur keine ahnung, was ich da noch anders einstellen soll......
Top
Top
 
Gast
#4 Geschrieben am: Do 15.07.2004, 23:48 (+00:45)
Report PostQuote Post

Unregistered







habe gerade noch eine interessante entdeckung gemacht.
e-mails an gmx zu schicken geht.
Warum geht das dann bei t-online nicht?
wenn das mit dem webserver richtig laufen soll muss das zu jedem provider gehen... ganz besonders zu t-online...
Top
Top
 
Roger Bobst
calac gmbh
#5 Geschrieben am: Fr 16.07.2004, 07:06 (+07:18)
Report PostQuote Post

AyomRank 5
Group Icon 2 Gruppe: Experte

Gruppe: Experte
Beiträge: 426
Mitglied seit: 15.02.2004


QUOTE
C:\>telnet 194.25.134.9
Verbindungsaufbau zu 194.25.134.9...Es konnte keine Verbindung hergestellt werde
n mit Host auf Port 23 : Verbinden fehlgeschlagen

Dass telnet nicht geht, überrascht mich nicht. Dies wäre grobfahrlässig, diesen Dienst da laufen zu lassen. Mails laufen über Port 25:

QUOTE
[robob@localhost robob]$ telnet 194.25.134.9 25
Trying 194.25.134.9...
Connected to mailin02.sul.t-online.com (194.25.134.9).
Escape character is '^]'.
220 mailin02.sul.t-online.de T-Online ESMTP receiver fssmtpd ready.
helo robob
250 Ok.


Das hatten wir in der Schweiz auch mal, als cablecam admins dachten, sie seien besonders schlau und hätten DIE Lösung gegen Spam gefunden: Sie haben damals einfach ganze ip Bereiche auf den Mailservern gesperrt, so dass Kunden vieler anderer Provider kaine Mails mehr an cabelcom Kunden senden konnten. Vielleicht hats bei der T-com ähnlcihe Schlaumeier

Gruss
Roger
Top
PMEmail PosterUsers Website
Top
 
Irene
irene.ch
#6 Geschrieben am: Fr 16.07.2004, 10:10 (+03:03)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Cablecom hat noch was anderes eingebaut, was auch T-Online verwenden könnte und sich bei gewissen Mailservern ganz perfid verhält: die Reverse-Auflösung. Bei der unangenehmen Variante davon hat der sendende Mailserver überhaupt keine Chance, auch nur "pieps" zu sagen - er wird gleich wieder rausgeschmissen.

@rund:
Ich geh davon aus, dass das Senden an GMX-Accounts wirklich über den Argo funktioniert. Dann überprüf doch mal mit Hilfe eines externen DNS-Servers (am besten dns00.btx.dtag.de, das ist einer von T-Online selbst) die Reverse-Auflösung Deiner externen IP-Adresse. Sieht dann etwa so aus, anstelle von 194.196.197.226 Deine externe IP angeben:

C:\>nslookup
Default Server: pluto.solar
Address: 192.168.253.9

> server dns00.btx.dtag.de
Default Server: dns00.btx.dtag.de
Address: 194.25.2.132

> set q=ptr
> 194.196.197.226
Server: dns00.btx.dtag.de
Address: 194.25.2.132

***
No domain name pointer (PTR) records available for 226.197.196.194.in-addr.arpa.
>

Wenn die Antwort (letzte Zeile) gleich lautet wie hier im Beispiel, dann gibt es für Deine IP-Adresse keine Reverse-Auflösung und Du wirst bei vielen Mailservern abblitzen. Kann sein, dass auch T-Online Deinem Argo deshalb nicht "zuhört".

Wenn die Antwort allerdings einen Namen zurückliefert, liegt es nicht an der Auflösung, sondern wirklich an der Verbindung zwischen dem Argo und dem T-Online-Server.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Gast
#7 Geschrieben am: Fr 16.07.2004, 10:32 (+00:22)
Report PostQuote Post

Unregistered







OK, ich hab mal das durchgespielt, was du mir empfohlen hast Irene.
So sah dann der Output aus:


C:\>
C:\>nslookup
DNS request timed out.
timeout was 2 seconds.
*** Der Servername für die Adresse 217.5.100.129 konnte nicht gefunden werden:
Timed out
Standardserver: dns03.btx.dtag.de
Address: 194.25.2.129

> server dns00.btx.dtag.de
Standardserver: dns00.btx.dtag.de
Address: 194.25.2.132

> set q=ptr
> 80.145.95.133
Server: dns00.btx.dtag.de
Address: 194.25.2.132

(root) nameserver = B.ROOT-SERVERS.NET
(root) nameserver = C.ROOT-SERVERS.NET
(root) nameserver = D.ROOT-SERVERS.NET
(root) nameserver = E.ROOT-SERVERS.NET
(root) nameserver = F.ROOT-SERVERS.NET
(root) nameserver = G.ROOT-SERVERS.NET
(root) nameserver = H.ROOT-SERVERS.NET
(root) nameserver = I.ROOT-SERVERS.NET
(root) nameserver = J.ROOT-SERVERS.NET
(root) nameserver = K.ROOT-SERVERS.NET
(root) nameserver = L.ROOT-SERVERS.NET
(root) nameserver = M.ROOT-SERVERS.NET
(root) nameserver = A.ROOT-SERVERS.NET
>


Ich weiß jetzt nicht, ob das gut oder schlecht ist. sieht auf jeden fall anders aus, als bei dir wink.gif
Bringt uns das weiter?
Hab dann mal den Nameservr im ARgo und in den TCP/IP-Settings auch umgeändert auf den dns00,
hat aber nichts gebracht.

P.S. was macht denn "set q=prt"?
Top
Top
 
Irene
irene.ch
#8 Geschrieben am: Fr 16.07.2004, 17:50 (+07:17)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Wenn Du das da

C:\>nslookup
DNS request timed out.
timeout was 2 seconds.
*** Der Servername für die Adresse 217.5.100.129 konnte nicht gefunden werden:
Timed out
Standardserver: dns03.btx.dtag.de
Address: 194.25.2.129


von dem Argo-PC aus gemacht hast, dann ist anscheinend die DNS-Einstellung dieses PC oder des Routers (falls der DNS-Weiterleitung macht) nicht ganz richtig. Würd ich mal korrigieren.

Die Antwort mit den vielen Root-Servers ist blöd; ich weiss auch nicht ob das jetzt gut oder schlecht ist - der Server weigert sich jedenfalls, diese Auflösung zu machen. Jedenfalls sollte der DNS-Server im Argo und in den TCP/IP-Einstellungen unbedingt auf den DNS-Server Deines Providers eingestellt sein. Alles andere führt zu Problemen.

Ich hab grad jetzt Deine IP von mir aus auflösen lassen, und das Resultat war ok; d.h. wenn die IP jetzt (18:44h schweizer Zeit) noch dieselbe ist, dann ist die Reverse-Auflösung nicht das Problem. Dann liegts an der Verbindung zwischen dem Argo und dem T-Online-Server.

Das "set q=ptr" setzt den Abfragetyp auf "Pointer", also auf die umgekehrte (reverse) Namensauflösung. Auf deutsch etwa "gib mir den zugehörigen Namen für die IP-Adresse x.x.x.x".

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Gast
#9 Geschrieben am: Sa 17.07.2004, 17:21 (+23:31)
Report PostQuote Post

Unregistered







also erstaunlicherweise funzt das mailversenden jetzt wieder weder zu gmx, noch zu t-online ohmy.gif
also eigentlich gar nirgends hin wink.gif
der telnet von port 25 auf gmx geht aber noch. zu t-online funzt der weiterhin nicht.
erstaunlicherweise ist mir aber auch ein mal (aber wirklich nur ein einziges mal) eine mail zu t-online durchgegangen. keine ahnung warum......
kann man dieses verhalten irgendwie erklären?
oder hat evtl jemand einen tipp, was noch ein guter webserver wäre den auch leute, die sich nicht so toll in der smtp/pop-welt auskennen konfiurieren können oder zu dem es ein gutes tutorial gibt? (hamster wäre nach der beschreibung aus dem rennen wink.gif )
Top
Top
 
Irene
irene.ch
#10 Geschrieben am: Sa 17.07.2004, 18:42 (+01:20)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Das Verhalten könnte man dann erklären, wenn man mit Ethereal an dem betreffenden PC sitzen und mal den Traffic analysieren könnte.
Ich würd aber einfach mal auf ein Verbindungsproblem tippen, das durch den Router und/oder Zonealarm verursacht wird.

QUOTE (rund @ Sa 17.7.2004, 18:21)
oder hat evtl jemand einen tipp, was noch ein guter webserver wäre den auch leute, die sich nicht so toll in der smtp/pop-welt auskennen konfiurieren können oder zu dem es ein gutes tutorial gibt?

Suchst Du nun einen Webserver oder einen Mailserver? Wenn Du das Mailproblem lösen willst, dann nützt Dir auch eine andere Mailserversoftware nix. Weil jede Mailsoftware macht genau das gleiche wie Du selbst mit Telnet: eine Verbindung auf Port 25 des Empfänger-Mailservers. Wenn das manuell nicht geht, dann kanns auch keine Software.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Gast
#11 Geschrieben am: Sa 17.07.2004, 21:15 (+02:33)
Report PostQuote Post

Unregistered







also ich hab mir jetzt mal ethereal installiert und hab mal kurz mitgesniffert.
demnach kommen aber 0 pakete von t-online zurück. ich hab 3 stück versendet, aber keine antwort erhalten. in dem päckchen selbst steht jetzt nicht grad was tolles drin. soll ich mein augenmerk auf etwas spezielles richten?
btw. ja, ich meinte im obrigen post schon mailserver. ich verwechsel das nur manchmal, weil das alles der selbe pc ist wink.gif
Top
Top
 
Irene
irene.ch
#12 Geschrieben am: So 18.07.2004, 12:42 (+15:27)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


QUOTE (rund @ Sa 17.7.2004, 22:15)
demnach kommen aber 0 pakete von t-online zurück. ich hab 3 stück versendet, aber keine antwort erhalten. in dem päckchen selbst steht jetzt nicht grad was tolles drin. soll ich mein augenmerk auf etwas spezielles richten?

Nö, nix spezielles; Ethereal sagt also, es geht was raus und es kommt nix zurück.

Jetzt wissen wir also definitiv, dass es ein Verbindungsproblem ist. Die nächste Frage lautet: wer oder was verursacht dieses Problem? Mögliche Antworten: Zonealarm, der Router oder Dein Internetprovider (oder T-Online selbst, nehm ich aber mal nicht an). So findest Du die Antwort:

- Du kannst versuchen, eine Telnet-Verbindung auf meinen Mailserver, Port 25, zu machen und das mitzusniffern (die IP dieses Servers erhältst Du per PN). Wenn das geht, liegt das Problem ausserhalb Deines Routers - andernfalls liegt es beim Router oder bei Zonealarm.

- Falls Dein Router ein Log hat, kannst Du in diesem Log schauen, ob die ausgehenden Pakete durch den Router durchgehen. Wenn sie überhaupt nicht bis zum Router kommen, liegt das Problem bei Zonealarm; ansonsten beim Router.

- Du kannst Zonealarm deinstallieren, denn es besteht ein Unterschied zwischen ausgeschaltetem und deinstalliertem Zonealarm (vorher die Konfiguration sichern). Wenn es dann geht, lag das Problem bei Zonealarm.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Roger Bobst
calac gmbh
#13 Geschrieben am: So 18.07.2004, 19:54 (+07:11)
Report PostQuote Post

AyomRank 5
Group Icon 2 Gruppe: Experte

Gruppe: Experte
Beiträge: 426
Mitglied seit: 15.02.2004


Wenn ich die Berichte hier so lese, glaub ich, kann man ausschliessen, dass ein Problem mit Zonealarm usw. vorliegt. Vorallem, weil MAilsenden zu gewissen ISP ja geht. Also scheint die Vermutung von Irene als Wahrscheinlich, dass die Mailserver von T-Online gewisse Anforderungen an Senderips stellen.
Für diese Fälle kann man bei den meisten Mailservern Transportrouten einstellen. Da würde ich nun eine Route definieren, dass alle Mails für tonline über den SMTP Server deines ISP laufen.

Bin gespannt, was mit dieser Konfiguration passiert

Gruss
Roger
Top
PMEmail PosterUsers Website
Top
 
Irene
irene.ch
#14 Geschrieben am: So 18.07.2004, 22:23 (+02:29)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Ich bin auch sehr interessiert zu erfahren, wo schlussendlich das Problem lag. Ein genau solches Problem hatt ich noch nie, und es könnte ja sein, dass ein Kunde mal sowas hat...

@Roger:
Die Idee mit dem Mailserver des ISP ist gut, nur müsste dann wahrscheinlich der ISP das Relay für diesen Argo freigeben, oder aber der Argo müsste sich bei jedem Senden authentifizieren (je nach Konfiguration beim ISP).

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Roger Bobst
calac gmbh
#15 Geschrieben am: Mo 19.07.2004, 09:47 (+11:24)
Report PostQuote Post

AyomRank 5
Group Icon 2 Gruppe: Experte

Gruppe: Experte
Beiträge: 426
Mitglied seit: 15.02.2004


QUOTE
nur müsste dann wahrscheinlich der ISP das Relay für diesen Argo freigeben, oder aber der Argo müsste sich bei jedem Senden authentifizieren (je nach Konfiguration beim ISP).

Das glaub ich hingegen nicht, weil diese Mailserver alles aus dem IP Bereich des
jeweiligen Providers annehmen. Ich habe bisher noch keinen ISP gesehen, wo ich mich als User hätte beim SMTP Server anmelden müssen. Der Agro wäre in dem Fall einfach ein normaler Mailsender, wie zum Beispiel Outlook...
Top
PMEmail PosterUsers Website
Top
 
Gast
#16 Geschrieben am: Mo 19.07.2004, 13:35 (+03:47)
Report PostQuote Post

Unregistered







Also.....
Mails an GMX und co. gehen wieder, da war nur der DNS nicht mehr erreichbar.
Was T-Online angeht hatte ich mal eine Mail geschrieben, die mir dann wie folgt beantwortet wurde:


Ihr Mail Transport Agent möchte die eMails bei unseren MX-Servern
abliefern. Diese nehmen jedoch keine eMails an, welche direkt von
Dialup-IPs des Telekom-Backbones eingeliefert werden.

Das bedeutet, Sie müssten entweder alle eMails oder zumindest die
eMails, welche an T-Online-Adressen geschickt werden, über einen
Smarthost einliefern.

Wenn Sie nur die eMails an T-Online-Adressen über einen Smarthost
einliefern möchten, geht das je nachdem welche Software Sie verwenden
wie folgt:

SENDMAIL:

Das Feature "mailertable" muss in der sendmail.cf aktiviert sein. Dann
genügen die folgenden Einträge in der Datei /etc/mail/mailertable [1] :

t-online.de smtp:[smtprelay.t-online.de]
t-online.com smtp:[smtprelay.t-online.de]
t-online.at smtp:[smtprelay.t-online.de]
t-dialin.net smtp:[smtprelay.t-online.de]

Nach Änderungen an der Datei bitte den Befehl
makemap hash mailertable.db < mailertable
ausführen, denn nur dann werden die Änderungen wirksam.


EXIM:

Hier genügt ein Eintrag in der Datei /etc/exim.conf [1]:

#############################################################
# ROUTERS CONFIGURATION #
# Specifies how remote addresses are handled #
#############################################################
# A remote address is passed to each in turn until it is accepted. #
#############################################################
# Remote addresses are those with a domain that does not match any item
# in the "local_domains" setting above.

# --------------------------------------------------------------- #
t_online:
driver = domainlist
transport = remote_smtp
route_list = "^t-online\.(de|at|com)|t-dialin\.net$ \
smtprelay.t-online.de bydns_a"
# --------------------------------------------------------------- #

Wichtig: diese Regel muss als erste vor allen anderen in der "Routers
Configuration" stehen; die Sektionsüberschrift sollte in der Datei
leicht zu finden sein.


POSTFIX:

In der Datei /etc/postfix/main.cf [1] muss folgende Zeile vorhanden
sein:

transport_maps = hash:/etc/postfix/transport

In dieser Datei /etc/postfix/transport tragen Sie dann ein:

t-online.de smtp:[smtprelay.t-online.de]
t-online.com smtp:[smtprelay.t-online.de]
t-online.at smtp:[smtprelay.t-online.de]
t-dialin.net smtp:[smtprelay.t-online.de]

Nach den Änderungen führen Sie bitte die Befehle
postmap /etc/postfix/transport
postfix reload
aus.


MICROSOFT EXCHANGE 5.5:

1. Exchange Administrator starten
2. Im Standort-Baum auf 'Verbindungen'
3. Eintrag 'Internet Mail-Dienst'
4. Register 'Verbindungen'
5. Schalftfläche 'E-Mail-Domäne...'
6. Schalftfläche 'Hinzufügen'
7. E-Mail-Domäne: t-online.de
8. 'Nachrichten für diese Domäne an folgenden Host weiterleiten:'
smtprelay.t-online.de
9. 'OK'
10. Dienst 'MS Exchange Internet Mail' neu starten


QMAIL:

Es genügt folgender Eintrag in der Datei /var/qmail/control/smtproutes
[1]:

t-online.de:smtprelay.t-online.de
t-online.at:smtprelay.t-online.de
t-online.com:smtprelay.t-online.de
t-dialin.net:smtprelay.t-online.de

Eine nähere Beschreibung der Datei "smtproutes" erhält man mit dem
Befehl "man 8 qmail-remote".


Wir sind davon ausgegangen, dass Sie nicht (nur) Ihre T-Online
eMail-Adresse verwenden möchten, sondern auch andere Adressen. Deshalb
müssten Sie den SMTP-Server smtprelay.t-online.de verwenden, da dieser
im Gegensatz zum Standard-Server mailto.t-online.de die Absenderadresse
nicht automatisch auf Ihre T-Online-Adresse setzt.

Für die Nutzung von smtprelay.t-online.de müssten Sie sich ab dem URL
<http://service.t-online.de/c/00/01/35/1350.html> zu diesem Dienst
anmelden.

Falls Sie nur eMails mit Ihrer T-Online-Adresse versenden möchten,
können Sie statt smtprelay.t-online.de natürlich auch den Server
mailto.t-online.de verwenden.

Selbstverständlich können Sie Ihre Mails auch über einen anderen
SMTP-Relayserver senden, wenn Sie z.B. eine eigene Domain haben über
denjenigen des betreffenden Providers.


[1] Die Datei kann evtl. je nach Distribution auch an einem anderen Ort
liegen.

Mit freundlichen Grüßen
Julia Fischer
--
abuse@rx.t-online.de - T-Online International AG


Jetzt wär es ja mal interessant wie ich weiter vorgehen kann ^^
unix hab ich ja nicht und mit den ms-servern kenn ich mich 0 aus.
Mit argo steh ich wohl auf verlorenem posten, richtig?

¤dit: Hab gerade mal auf den Link geschaut... das würde ja 2,95/Monat kosten... das geht nicht..... gibts denn jetzt noch eine (kostenlose) Lösung für mich?
Top
Top
 
Roger Bobst
calac gmbh
#17 Geschrieben am: Mo 19.07.2004, 14:34 (+00:59)
Report PostQuote Post

AyomRank 5
Group Icon 2 Gruppe: Experte

Gruppe: Experte
Beiträge: 426
Mitglied seit: 15.02.2004


QUOTE
Mit argo steh ich wohl auf verlorenem posten, richtig?

Keine Ahnung, ich kenne den Agro Mailserver nicht, kann mir aber nicht vorstellen, dass er solche Transport Einstellungen nicht beherrscht.

Aber das Transportproblem könnte man sonst notfallmässig auch mit einer kleinen Bastelübung umgehen.
Top
PMEmail PosterUsers Website
Top
 
Irene
irene.ch
#18 Geschrieben am: Mo 19.07.2004, 17:53 (+03:18)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


QUOTE (rund @ Mo 19.7.2004, 14:35)
Mit argo steh ich wohl auf verlorenem posten, richtig?

Der Argo hat meines Wissens keine solchen Einstellungen, aber evtl. könntest Du das über entsprechende MX-Einträge im lokalen Hosts-File einstellen. Hab das noch nie versucht, deshalb bin ich nicht sicher, obs geht ;-)

QUOTE (rund @ Mo 19.7.2004, 14:35)
Hab gerade mal auf den Link geschaut... das würde ja 2,95/Monat kosten... das geht nicht..... gibts denn jetzt noch eine (kostenlose) Lösung für mich?

Kostenlos gings höchstens mit einem Mailserver, der Dein Account bei T-Online zum Senden verwendet und sich bei jedem Senden authentifiziert (so wie das Dein Mailclient auch macht). Das sollte dann auch über ein GMX- oder sonstiges Account gehen, weil ein Mailserver sieht nicht, ob er ein Mail von einem Mailclient oder einem anderen Mailserver bekommt. Nachteile:

1. könnte es je nach Vertragsbedingungen illegal sein (was zu deftigen Massnahmen seitens der beteiligten Provider führen kann!)
2. sehen die Mailempfänger in den Kopfzeilen, über welche Server der Versand gemacht wurde (kann unseriös wirken, je nachdem zu welchem Zweck diese Mails versendet werden)

Obs überhaupt einen Mailserver gibt, der die Authentifizierung beim Senden unterstützt, weiss ich nicht.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
Gast
#19 Geschrieben am: Di 20.07.2004, 13:41 (+19:48)
Report PostQuote Post

Unregistered







QUOTE (Roger Bobst @ Mo 19.7.2004, 14:34)
QUOTE
Mit argo steh ich wohl auf verlorenem posten, richtig?

Aber das Transportproblem könnte man sonst notfallmässig auch mit einer kleinen Bastelübung umgehen.

Kannst du etwas genauer darauf eingehen, was du damit meinst?

@Irene:
was meinst du mit den mx-einstellungen?

Ich werd mal versuchen irgendwie auf ms exchange evtl. umzusteigen, da ich derzeit naber nur remote-zugriff auf den webserver hab, kann ich den exchange erst wieder in einer woche, wenn ich vom urlaub zurück bin installieren...
Top
Top
 
Roger Bobst
calac gmbh
#20 Geschrieben am: Di 20.07.2004, 13:59 (+00:17)
Report PostQuote Post

AyomRank 5
Group Icon 2 Gruppe: Experte

Gruppe: Experte
Beiträge: 426
Mitglied seit: 15.02.2004


wie gesagt, das ist eine Bastellösung:

öffne das hosts File auf dem Server (c:\windows\system32\drivers\etc) und füge da was im stil von dem ein:
CODE

127.0.0.1       localhost
#ip des mailsservers deines ISP
123.123.123.112 mail.t-online.de


damit überschreibst du die offiziellen DNS server der t-online. Diesen Eintrag musst du natürlcih für jeden Mailserver der t-online machen.

Gruss
Roger
Top
PMEmail PosterUsers Website
Top
 
Thema wird von 0 Benutzer(n) gelesen (0 Gäste und 0 anonyme Benutzer)
0 Mitglieder:

Topic Options Seiten: (2) [1] 2  Reply to this topicStart new topicStart Poll

 


> Ähnliche Themen
Suche: E-Mail Adressen Sancheck 377 2 Fr 17.10.2014, 10:02
Javari wird nun Teil von AmazonFashion - keine 15% Bottle 458 0 Di 27.05.2014, 14:28
Gibt es tatsächlich keine fertige Lösung? Maneo 704 0 Fr 25.04.2014, 12:05
Tool zum E-Mail-Marketing Alexander Weise 6160 21 Fr 14.02.2014, 15:09
Suche Software für E-Mail, Social Media und Mobile Martin Ha 1163 7 Do 23.05.2013, 15:41
Hilfe: Mail kommt bei einigen Anbietern nicht an ? Japs 823 10 Mi 13.03.2013, 07:45
keine doppelten Datensätze eintragen NullAhnung 592 4 Do 14.02.2013, 19:47
Lohnt sich E-Mail Marketing Ernesto 1776 5 Mo 11.02.2013, 17:06
Tägliche Rankings im Mail bekommen? Dito 590 2 Fr 25.01.2013, 12:27
Bilder Von Erotikprodukten(keine Personen) JohnnyB 946 4 Di 22.01.2013, 16:08


Günstig werben auf Ayom:
Kontakt: ayom@small-n-tall.com



Anzeigen

Textlinks kaufen oder anbieten





[Hier werben]

 

Statistiken:
Top 10 Autoren heute
Top 50 Autoren insgesamt