Anzeige - [Hier werben]
(?) Tags raten (?) (edit)
 
Reply to this topicStart new topicStart Poll
Diskussion

mail() php apache

versendet keine mails

realromeo76
Geschrieben am: Mo 5.07.2004, 12:06
Report PostQuote Post

AyomRank 2
****

Gruppe: Member (aktiv)
Beiträge: 16
Mitglied seit: 12.05.2004


hi Leute

Ich bin kurz vorm durchdrehen


php und Apache habe ich unter Windows xp zum laufen gebracht.
Nun versuche ich die php mail() funktion zu testen bekomme aber immer die selbe fehler meldung:


Warning: mail(): SMTP server response: 554 User unknown in G:\Programme\Apache Group\Apache2\htdocs\mailer.php on line 110

Ich habe schon sämtliche Foren durchgelesen aber irgendwie finde ich keine lösung
als mailserver habe ich den ArGosoft Mail Server installiert und soweit ich weiss auch richtig konfiguriert

in der php.ini sieht es unter mail function soaus:
---------------------------------------
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25
sendmail_from = localhost@localhost.de

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =
------------------------------------------
hat irgend jemand eine idee was ich falsch mache oder übersehen habe

ich danke schon mal im vorraus
Top
PMEmail Poster
Top
 
 
Irene
irene.ch
#2 Geschrieben am: Mo 5.07.2004, 13:06 (+01:00)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


QUOTE (realromeo76 @ Mo 5.7.2004, 13:06)
Warning: mail(): SMTP server response: 554 User unknown

Diese Meldung kommt vom Mailserver, was bedeutet, dass Dein Code soweit stimmt. Ein 554 User unknown bedeutet, dass die Empfängeradresse auf dem Mailserver nicht existiert.

Je nach Einstellungen akzeptiert der Mailserver jeglichen Relay (dann sollte so ein Fehler nicht kommen). Andernfalls akzeptiert er nur Mails, die entweder von einem lokalen Absender - der sich normalerweise vor dem Senden autentifizieren muss - kommen oder für einen lokalen Empfänger bestimmt sind. (Lokaler Absender / lokaler Empfänger sind Mailaccounts, die auf dem Mailserver eingerichtet sind.)

Ich richte in solchen Fällen immer zuerst die Accounts auf dem Argo ein und teste diese mit Outlook Express o.ä. - erst wenn das geht, weiss ich dass alle Einstellungen stimmen. Dann kann ich die Outlook-Einstellungen (SMTP/POP3-Server, Mailadresse, Benutzername, Passwort, etc.) im Code verwenden.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
realromeo76
#3 Geschrieben am: Mo 5.07.2004, 13:33 (+00:26)
Report PostQuote Post

AyomRank 2
****

Gruppe: Member (aktiv)
Beiträge: 16
Mitglied seit: 12.05.2004


im argo kann bekomme ich diese ausgabe

------------------------------------------------------------------------------------------------
05.07.2004 14:24:29 - Requested SMTP connection from 127.0.0.1
05.07.2004 14:24:29 - SMTP connection with 127.0.0.1 ended. ID=5
05.07.2004 14:26:51 - [ 6] Delivering to realromeo76@web.de
05.07.2004 14:26:51 - [ 6] Attempting to deliver to the domain web.de
05.07.2004 14:26:51 - [ 6] Retrieved 2 MX records for domain web.de
05.07.2004 14:26:51 - [ 6] Trying the server mx-ha01.web.de: 217.72.192.149
05.07.2004 14:27:12 - [ 6] Winsock error when communicating with exchanger mx-ha01.web.de: [10065] No Route to Host
05.07.2004 14:27:12 - [ 6] Trying the server mx-ha02.web.de: 217.72.192.188
05.07.2004 14:27:34 - [ 6] Winsock error when communicating with exchanger mx-ha02.web.de: [10065] No Route to Host
05.07.2004 14:27:34 - [ 6] Server error: [10065] No Route to Host. Will retry in 0 hr 10 min
05.07.2004 14:27:34 - [ 7] Delivering to localhost@localhost.de
05.07.2004 14:27:34 - [ 7] Attempting to deliver to the domain localhost.de
05.07.2004 14:27:35 - [ 7] Retrieved 2 MX records for domain localhost.de
05.07.2004 14:27:35 - [ 7] Trying the server mx01.isb.net: 195.90.0.84
05.07.2004 14:27:55 - [ 7] Winsock error when communicating with exchanger mx01.isb.net: [10065] No Route to Host
05.07.2004 14:27:58 - [ 7] Trying the server bonbon.isb.net:
05.07.2004 14:28:00 - [ 7] Winsock error when communicating with exchanger bonbon.isb.net: [11001] Host not found
05.07.2004 14:28:00 - [ 7] Server error: [11001] Host not found. Will retry in 0 hr 10 min
------------------------------------------------------------------------------------------------

ich als dummy habe echt keine ahnung wo ich den fehler behebn soll
Top
PMEmail Poster
Top
 
Irene
irene.ch
#4 Geschrieben am: Mo 5.07.2004, 14:20 (+00:47)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Der Argo hat das Mail von PHP akzeptiert und versucht es jetzt weiterzuleiten:
QUOTE
05.07.2004 14:26:51 - [    6] Delivering to realromeo76@web.de
05.07.2004 14:26:51 - [    6] Attempting to deliver to the domain web.de
05.07.2004 14:26:51 - [    6] Retrieved 2 MX records for domain web.de
05.07.2004 14:26:51 - [    6] Trying the server mx-ha01.web.de: 217.72.192.149
05.07.2004 14:27:12 - [    6] Winsock error when communicating with exchanger mx-ha01.web.de: [10065] No Route to Host
05.07.2004 14:27:12 - [    6] Trying the server mx-ha02.web.de: 217.72.192.188
05.07.2004 14:27:34 - [    6] Winsock error when communicating with exchanger mx-ha02.web.de: [10065] No Route to Host
05.07.2004 14:27:34 - [    6] Server error: [10065] No Route to Host. Will retry in 0 hr 10 min


Dieses "no route to host" bedeutet, dass der Argo netzwerkmässig nicht zum Mailserver mx-ha01.web.de (217.72.192.149) durchkommt. Dann probiert er es mit dem zweiten Mailserver von web.de, da passiert aber dasselbe. Entweder eine Firewall blockiert das, oder der Argo hat ein Internet-Verbindungsproblem.
Genaueres müsstest Du mit dem Tracert-Befehl rausfinden können.

QUOTE

05.07.2004 14:27:34 - [    7] Delivering to localhost@localhost.de
05.07.2004 14:27:34 - [    7] Attempting to deliver to the domain localhost.de
05.07.2004 14:27:35 - [    7] Retrieved 2 MX records for domain localhost.de
05.07.2004 14:27:35 - [    7] Trying the server mx01.isb.net: 195.90.0.84
05.07.2004 14:27:55 - [    7] Winsock error when communicating with exchanger mx01.isb.net: [10065] No Route to Host
05.07.2004 14:27:58 - [    7] Trying the server bonbon.isb.net:
05.07.2004 14:28:00 - [    7] Winsock error when communicating with exchanger bonbon.isb.net: [11001] Host not found
05.07.2004 14:28:00 - [    7] Server error: [11001] Host not found. Will retry in 0 hr 10 min

Hier versucht der Server auch ein Mail weiterzuleiten, und zwar an die Domain localhost.de. Deren ersten Mailserver kann er wieder nicht erreichen (no route to host), und für den zweiten (bonbon.isb.net) findet er schon gar keine IP-Adresse. Die haben da im DNS was Falsches drin.

Falls das localhost.de nur für Dich intern sein soll und Du nicht wirklich ein Account dort hast, dann rate ich Dir dringend, das nicht mehr so zu probieren. Im dümmsten Fall wirst Du sonst als Spammer gebrandmarkt. Für lokale Versuche richtest Du am besten zwei Domains mit je einem Account auf dem Argo ein (oder halt eine Domains mit zwei Accounts), und schickst die Mails zwischen diesen zwei hin und her.

Griessli
Irene


--------------------
Top
PMUsers Website
Top
 
realromeo76
#5 Geschrieben am: Mo 5.07.2004, 16:33 (+02:13)
Report PostQuote Post

AyomRank 2
****

Gruppe: Member (aktiv)
Beiträge: 16
Mitglied seit: 12.05.2004


ich danke dir irene

hast mir echt geholfen es klappt jetzt
Top
PMEmail Poster
Top
 
Irene
irene.ch
#6 Geschrieben am: Mo 5.07.2004, 18:40 (+02:06)
Report PostQuote Post

AyomRank 7
**************

Gruppe: Ehrenmitglied, Ex-Moderator
Beiträge: 1115
Mitglied seit: 3.05.2004


Bittschön, freut mich smile.gif


--------------------
Top
PMUsers Website
Top
 
Thema wird von 0 Benutzer(n) gelesen (0 Gäste und 0 anonyme Benutzer)
0 Mitglieder:

Topic Options Reply to this topicStart new topicStart Poll

 


> Ähnliche Themen
Tool zum E-Mail-Marketing Alexander Weise 5719 21 Fr 14.02.2014, 15:09
virtualhost apache online modifizieren Sancheck 839 1 Fr 27.12.2013, 13:34
Suche Software für E-Mail, Social Media und Mobile Martin Ha 1096 7 Do 23.05.2013, 15:41
Hilfe: Mail kommt bei einigen Anbietern nicht an ? Japs 788 10 Mi 13.03.2013, 07:45
Lohnt sich E-Mail Marketing Ernesto 1637 5 Mo 11.02.2013, 17:06
Tägliche Rankings im Mail bekommen? Dito 572 2 Fr 25.01.2013, 12:27
Variable in Mail wird nicht angezeigt... NullAhnung 555 2 Do 18.10.2012, 15:02
E-Mail Daten Veröffentlichung, jemand betroffen? Ronny84 1098 2 So 15.07.2012, 01:38
HTML Mail Problem Sancheck 875 3 Fr 18.05.2012, 18:19
Video Mail-Benachrichtigung FilOO 641 0 Di 28.02.2012, 11:10


Günstig werben auf Ayom:
Kontakt: ayom@small-n-tall.com



Anzeigen

Textlinks kaufen oder anbieten





[Hier werben]

 

Statistiken:
Top 10 Autoren heute
Top 50 Autoren insgesamt