Anmelden, um zu folgen  
Folger 0
Josh

onclick='location.href="xyz"' macht probleme

2 Beiträge in diesem Thema

hi ihr javascript experten! smile.gif

ich hab n menü mit nem onclick:

onclick='location.href="xyz"';

allerdings geht das nicht so wie ich will, denn statt einfach auf die datei xyz zu verweisen lädt es im IE gleich den ganzen pfad des bisherigen docs mit dem xyz angehängt.

also wenn ich im dokument index.php?a=b dieses onclick platziere, so lädt es

index.php?a=bxyz

statt einfach nur xyz! wie kann ich das lösen?
thanx & gr33tz
j0sh

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Kommt mir bekannt vor, kann aber nicht dasselbe sein wie ich manchmal hab. Bei mir tut das Dotnet Framework, wenn es einen Link im Seiten-"Template" findet den es - aus unerfindlichen Gründen - für falsch hält, diesen Link für die Ausgabe im Browser anpassen. Manchmal tuts einen relativen Pfad "absolutieren" d.h. hängt ein "http://" vornedran; manchmal tuts einen "/" vornedran oder sonstwas falsches. Ich hatte aber gemeint, dass manchmal sogar der IE einen Link verhunzt, der im HTML-Source ansonsten richtig wär.

Da ich kein PHP kenn, weiss ich nicht wo Dein beschriebener Fehler wirklich herkommt. Jedenfalls, wenns nicht anders geht, lös ich das dann so: im serverside Code eine Variable setzen z.B. sClick="onclick='location.href="xyz"';" und dann im Seiten-"Template" diese Variable mit <%=sClick%> an der entsprechenden Stelle ausgeben. Damit umgeh ich die automatische Templateverarbeitung des Dotnet Frameworks für diesen JS-Schnipsel. Ist ein Bastel-Workaround, aber es geht ;-)

Griessli
Irene

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
nach stundenlangem wühlen hab ichs mehr oder weniger herausbekommen:

meine 404 seite im server gab den link falsch an, wenn ich auf eine nicht-existente seite referenzierte. sobald ich eine existente php seite angab, funktionierte es! und ich war doof genug, stundenlang mit falschen links rumzupröbeln, weil es ja eigentlich nicht darauf hätte ankommen sollen! sad.gif sehr dubiose sache, weiss nicht, obs jetzt am browser liegt oder am server... naja, jedenfalls wieder einmal ziemlich teuer ein kleines stückchen erfahrung eingekauft... scheisse nochmal, ich könnte mich ab solchen dingen zu tode ärgern... mad.gif

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstellen Sie einen Account oder melde Sie sich an um kommentieren zu können

You need to be a member in order to leave a comment

Create an account

Registrieren Sie einen neuen Account in unserer Community. Es ist einfach!


Register a new account

Anmelden

Haben Sie bereits einen Account? Dann melden Sie sich hier an.


Jetzt Anmelden
Anmelden, um zu folgen  
Folger 0